Tener en cuenta que la sesión IBGP es sólo una lógica; Es decir, no hay conexión física entre R1 y R3; Están formando la sesión IBGP a través de R2. También he utilizado rutas estáticas para establecer la conectividad.
R1
hostname R1!
interface Loopback34
ip address 192.168.34.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.0.12.1 255.255.255.0
!
router bgp 1
network 192.68.34.0
neighbor 10.0.12.2 remote-as 1
neighbor 10.0.23.3 remote-as 1
!
ip route 10.0.23.0 255.255.255.0 10.0.12.2
!
R2
hostname R2!
interface FastEthernet0/0
ip address 10.0.12.2 255.255.255.0
!
interface FastEthernet0/1
ip address 10.0.23.2 255.255.255.0
!
router bgp 1
neighbor 10.0.12.1 remote-as 1
neighbor 10.0.23.3 remote-as 1
!
R3
hostname R3!
interface FastEthernet0/0
ip address 10.0.23.3 255.255.255.0
!
router bgp 1
neighbor 10.0.23.2 remote-as 1
neighbor 10.0.12.1 remote-as 1
!
ip route 10.0.12.0 255.255.255.0 10.0.23.2
!
Pruebas
R3#
! Levanta la sesion de BGP
*Jun 1 15:30:44.283: %BGP-5-ADJCHANGE: neighbor 10.0.23.2 Up
!
!
! Se ve la red en la tabla de ruteo de BGP
R3#sh ip bgp
BGP table version is 2, local router ID is 10.0.23.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>i192.168.34.0 10.0.12.1 0 100 0 i
R3#