Objetivos:
Interconectar
las 2 redes LAN01 y LAN02
Debe funcionar
BGP en el proveedor ISP
BGP debe permitir el paso de las rutas de OPSF ID 1 entre CE1 y CE2
BGP debe permitir el paso de las rutas de OPSF ID 1 entre CE1 y CE2
hostname PE1
!
interface Loopback0
ip address 11.11.11.11
255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.1.1
255.255.255.0
!
interface FastEthernet0/1
ip address 10.3.3.1
255.255.255.0
!
interface FastEthernet1/0
ip address 10.5.5.1
255.255.255.0
!
router ospf 1
router-id 22.22.22.22
log-adjacency-changes
redistribute bgp 1000 subnets
network 10.1.1.0 0.0.0.255 area
0
!
router ospf 2
log-adjacency-changes
network 10.3.3.1 0.0.0.0 area 0
network 10.5.5.1 0.0.0.0 area 0
network 11.11.11.11 0.0.0.0
area 0
!
router bgp 1000
no synchronization
bgp log-neighbor-changes
bgp redistribute-internal
redistribute ospf 1
neighbor 22.22.22.22 remote-as
1000
neighbor 22.22.22.22
update-source Loopback0
neighbor 33.33.33.33 remote-as
1000
neighbor 33.33.33.33
update-source Loopback0
no auto-summary
!
|
hostname PE2
!
interface Loopback0
ip address
33.33.33.33 255.255.255.255
!
interface FastEthernet0/0
ip address
10.2.2.1 255.255.255.0
!
interface FastEthernet0/1
ip address
10.4.4.1 255.255.255.0
!
interface FastEthernet1/0
ip address
10.5.5.2 255.255.255.0
!
router ospf 1
router-id
44.44.44.44
log-adjacency-changes
redistribute
bgp 1000 subnets
network
10.2.2.0 0.0.0.255 area 0
!
router ospf 2
log-adjacency-changes
network
10.4.4.0 0.0.0.255 area 0
network
10.5.5.0 0.0.0.255 area 0
network
33.33.33.33 0.0.0.0 area 0
!
router bgp 1000
no
synchronization
bgp
log-neighbor-changes
bgp
redistribute-internal
redistribute
ospf 1
neighbor 11.11.11.11
remote-as 1000
neighbor
11.11.11.11 update-source Loopback0
neighbor
22.22.22.22 remote-as 1000
neighbor
22.22.22.22 update-source Loopback0
no
auto-summary
!
|
hostname CE1
!
interface
Loopback1
ip
address 1.1.1.1 255.255.255.255
!
interface
Loopback2
ip
address 2.2.2.2 255.255.255.255
!
interface
Loopback3
ip
address 3.3.3.3 255.255.255.255
!
interface
Loopback4
ip
address 4.4.4.4 255.255.255.255
!
interface
FastEthernet0/0
ip
address 10.1.1.2 255.255.255.0
!
router ospf 1
router-id
11.11.11.11
log-adjacency-changes
network
1.1.1.1 0.0.0.0 area 0
network
2.2.2.2 0.0.0.0 area 0
network
3.3.3.3 0.0.0.0 area 0
network
4.4.4.4 0.0.0.0 area 0
network 10.1.1.0 0.0.0.255 area 0
!
|
hostname CE2
!
interface Loopback5
ip address 5.5.5.5
255.255.255.255
!
interface Loopback6
ip address
6.6.6.6 255.255.255.255
!
interface Loopback7
ip address
7.7.7.7 255.255.255.255
!
interface Loopback8
ip address
8.8.8.8 255.255.255.255
!
interface FastEthernet0/0
ip address
10.2.2.2 255.255.255.0
!
router ospf 1
router-id
33.33.33.33
log-adjacency-changes
network
5.5.5.5 0.0.0.0 area 0
network
6.6.6.6 0.0.0.0 area 0
network
7.7.7.7 0.0.0.0 area 0
network
8.8.8.8 0.0.0.0 area 0
network 10.2.2.0
0.0.0.255 area 0
!
|
hostname ISP
!
interface Loopback0
ip address
22.22.22.22 255.255.255.255
!
interface FastEthernet0/0
ip address
10.3.3.2 255.255.255.0
!
interface FastEthernet0/1
ip address
10.4.4.2 255.255.255.0
!
router ospf 2
log-adjacency-changes
network
10.3.3.0 0.0.0.255 area 0
network
10.4.4.0 0.0.0.255 area 0
network
22.22.22.22 0.0.0.0 area 0
!
router bgp 1000
no
synchronization
bgp
log-neighbor-changes
neighbor
11.11.11.11 remote-as 1000
neighbor
11.11.11.11 update-source Loopback0
neighbor 33.33.33.33
remote-as 1000
neighbor
33.33.33.33 update-source Loopback0
no auto-summary
!
|